Back to overview
Downtime
Singpass Facial Verification is down
May 21 at 01:53pm GMT+8
Affected services
Singpass Auth Server
Resolved
May 21 at 03:05pm GMT+8
We have resolved the issue and Singpass facial verification has now resumed as per normal.
Affected services
Singpass Auth Server
Created
May 21 at 01:53pm GMT+8
Users may experience difficulties accessing services using facial verification. We are working to resolve this issue. Meanwhile, please log in using the Singpass app or SMS One-Time Passwords. We apologise for any inconvenience caused.
Affected services
Singpass Auth Server